Page 2 of 2

Re: Help with MMapper2

Posted: Thu Jun 17, 2010 6:04 pm
by avamoore
ah yes, that did fix the problem. thanks! also, how do i update a room description? like say if the map has "xxx" stored as room description for a room, how can i change it to "yyy" ?

i tried selecting the room, and clicking edit selected room, but in "selection" tab it won't let me change it. it only says "room has been online updated"

Re: Help with MMapper2

Posted: Mon Jun 21, 2010 12:15 am
by Agaba
I am having trouble with MMapper syncing to different characters. It works for 2 of them, but i have 2 old chars i unretired and it just does not work.

XML is turned on, all colour is set default on all chars, same JMC client and MMapper. It just stays in last room i was in and does not update. If i go to the chars that work, it works like a charm. Any thoughts??

Re: Help with MMapper2

Posted: Mon Jun 21, 2010 12:53 am
by Elestir
prompt all

Re: Help with MMapper2

Posted: Mon Jun 21, 2010 6:32 am
by Waba
"brief off", "spam on" may help as well.

Re: Help with MMapper2

Posted: Mon Oct 11, 2010 1:13 pm
by dianos
I've just downloaded the latest code from svn, but I'm having trouble compiling it.

Basically, I just open a command prompt in the mmapper2/src directory and type:
cmake -G "MinGW Makefiles"

it checks a few things and says they are working, then it says this:
CMake Error at CMakeLists.txt:76 (QT_QUERY_QMAKE):
Unknown CMake command "QT_QUERY_QMAKE".
I've searched around a bit, but failed to find the solution. I don't really know much about cmake or Qt, so I don't know what the problem is. By the looks of it, cmake is being asked to do something related to Qt, and cmake is saying "I've never heard of Qt..."

(I do have Qt installed. I used Qt creator to successfully compile the old mmapper2 code that I had before updating it.)

Re: Help with MMapper2

Posted: Tue Oct 12, 2010 11:30 am
by Kalev
I've hopefully fixed it, can you update and give it a try? ... w=revision

Re: Help with MMapper2

Posted: Wed Oct 13, 2010 3:22 am
by dianos
It looks like that particular problem is fixed — so cmake gets a bit further, but now there is another problem:
CMake Error at CMakeLists.txt:160 (QT4_WRAP_CPP):
Unknown CMake command "QT4_WRAP_CPP".
It sounds like I need some kind of special QT module for cmake or something. I don't know.

(by the way, I probably won't actually do anything with the code other than compile it... so don't spend too much time on my behalf.)

Re: Help with MMapper2

Posted: Wed Oct 13, 2010 9:12 am
by Kalev
Huh, that's strange. What version of cmake do you have?

Please make sure you get the same result with a fresh svn checkout. Could be some generated files lying around and causing problems.

Re: Help with MMapper2

Posted: Wed Oct 13, 2010 3:01 pm
by dianos
Getting a fresh svn checkout didn't directly solve the problem... but it did lead to the solution. :)

The problem was that I had only checked out the mmapper/src directory. (Way back when I was editing mmapper in the past, that was all that I needed). Anyway, when I checked out the full mmapper directory instead, I saw that there are actually some build instructions and stuff like that. As I said, I was originally just going into the src directory and typeing cmake -G "MinGW Makefiles" (and it wasn't working). This time, I started in the mmapper directory and typed winbuild... I had to manually change %path% and %qmakespec%, but with that it compiled...

... but failed to link. :(

I'm now seeing a bunch of things like this:
..\3rdparty\qtiocompressor\libqtiocompressor.a(qtiocompressor.cpp.obj):C:/Programming/mmapper/3rdparty/qtiocompressor/qtiocompressor.cpp:126:undefined reference to `deflate'

That's probably because I don't have Qt / mingw set up properly or something. Maybe I'll look into it again tomorrow. Progress has been made. :)

(by the way, cmake version 2.8.2)

Re: Help with MMapper2

Posted: Wed Oct 13, 2010 6:24 pm
by Kalev
OK, looks like for some reason it didn't try to link with the zlib library when using mingw; should be fixed in: ... w=revision

Re: Help with MMapper2

Posted: Fri Nov 19, 2010 11:14 pm
by dekard
I have a mac. I am using Mudlet - is there a better client for mac than this? I just downloaded mmapper but cant figure out how to set Mudlet to localhost port 4242. Can anyone help me? Thanks

Re: Help with MMapper2

Posted: Sat Nov 27, 2010 4:15 am
by science
Interesting - I hadn't seen mudlet.

I use console + powwow. It compiles from source pretty easily once you have gcc installed (install xcode from the installer disk).

He also has some good scripts posted. Powwow is one of the most used clients, so there are a decent selection of scripts to copy / start from online.

Re: Help with MMapper2

Posted: Mon Nov 29, 2010 3:19 am
by dekard
hmmmm I went to your link and downloaded the file but cant figure out how to install or run it - does it work on a mac? I am not too good with this kind of stuff... Any step by step instructions out there? Thanks

Re: Help with MMapper2

Posted: Sat Jul 28, 2012 10:01 am
by hawai
I have problem with win7, wintin++ and mmapper2. I cannot seem to connect to mmapper2 with wintin++. The same configuration
works on XP.

I can connect wintin++ to mume (without mmapper2). I can connect telnet to mmapper2 (without wintin++) and it connects to mume. But i cannot get the trio to work.

I have looked over the windows firewall - nothing is blocking anything.

Has anyone also experienced this and perhaps found a solution? (I am aware that mumers aren't using wintin++/tintin++ much)

Solution: dont connect to localhost 4242, but 4242 :D