New server linkspeed

Old MUME discussions.

Moderator: Builders

Forum rules
The posts in this forum should be related to MUME.
Locked
aldea
Posts: 6
Joined: Sun Aug 24, 2008 9:54 pm

New server linkspeed

Post by aldea » Mon Jul 27, 2009 10:02 pm

When the server was located in norway my link usually was below 35ms but after the move to *.ch my link has detoriated to 150-200ms and sometimes its around 250ms (which i find unplayable). I've tried traceroutes from different locations around europe including from where i play from (*.se) and it seems that my link is the worst among the tested servers. The most weird thing is that my ISP lookingglass shows a 35ms link to the new server which is exactly the speed i had to the old Mume server in Norway. So, anyone else playing from europe experiencing the same drop in linkspeed after the move ?

Sample link to new server.
Round-trip time: 191ms (kernel:288ms) Link options: sack wscale

Different traces (using: http://www.traceroute.org)

Here is from KTH (Sweden) - sub 40ms
1 nada-gw-222 (130.237.222.2) 0.570 ms 0.600 ms 0.295 ms
2 cn6-nada-p2p.gw.kth.se (130.237.211.213) 0.858 ms 0.719 ms 0.652 ms
3 a1g-cn6-p2p.gw.kth.se (130.237.0.1) 0.464 ms 0.459 ms 0.442 ms
4 c2sth-ae0-1001.sunet.se (193.11.0.197) 0.498 ms 0.490 ms 0.484 ms
5 se-tug.nordu.net (193.10.68.37) 0.931 ms 0.989 ms 0.941 ms
6 dk-uni.nordu.net (193.10.68.18) 17.206 ms se-fre.nordu.net (193.10.252.85) 1.049 ms 1.003 ms
7 dk-ore.nordu.net (193.10.68.25) 14.140 ms dk-ore.nordu.net (193.10.68.118) 10.687 ms dk-ore.nordu.net (193.10.68.25) 14.172 ms
8 nordunet.rt2.cop.dk.geant2.net (62.40.124.45) 10.692 ms 14.240 ms 10.679 ms
9 so-7-3-0.rt1.fra.de.geant2.net (62.40.112.49) 28.340 ms 28.298 ms 24.917 ms
10 so-7-0-0.rt1.gen.ch.geant2.net (62.40.112.69) 36.344 ms 32.891 ms 32.829 ms
11 swiCE2-10GE-1-1.switch.ch (62.40.124.22) 36.412 ms 32.941 ms 36.401 ms
12 swiCE3-10GE-1-4.switch.ch (130.59.36.210) 36.474 ms 33.144 ms 36.479 ms
13 swiEL2-10GE-1-3.switch.ch (130.59.37.66) 33.786 ms 33.825 ms 37.365 ms
14 swiYV2-G0-1.switch.ch (130.59.36.149) 34.287 ms 37.728 ms 37.662 ms
15 pub1.heig-vd.ch (193.134.216.2) 34.270 ms 37.765 ms 34.193 ms
16 *

And here is a test from my ISP (TeliaSonera, Sweden Stockholm) - sub 40ms
traceroute to mume.org (193.134.218.111), 30 hops max, 40 byte packets
1 s-bb2-link.telia.net (80.91.252.126) 0.406 ms s-bb1-link.telia.net (80.91.252.70) 50.226 ms s-bb1-link.telia.net (80.91.254.118) 0.288 ms
2 ffm-bb1-link.telia.net (80.91.251.145) 27.497 ms ffm-bb2-link.telia.net (80.91.251.147) 22.521 ms ffm-bb1-link.telia.net (80.91.251.145) 27.908 ms
3 zch-b1-link.telia.net (213.248.65.42) 33.185 ms zch-b1-link.telia.net (80.91.248.120) 33.356 ms zch-b1-link.telia.net (213.248.65.42) 33.183 ms
4 dante-01287-zch-b1.c.telia.net (213.248.79.190) 34.060 ms 33.764 ms 33.695 ms
5 swiZH2-10GE-1-3.switch.ch (130.59.36.130) [AS 559] 43.165 ms 33.907 ms 34.004 ms
6 swiNE2-G2-3.switch.ch (130.59.36.97) [AS 559] 37.605 ms 47.968 ms 37.561 ms
7 swiNE1-G1-4.switch.ch (130.59.36.117) [AS 559] 36.005 ms 36.104 ms 36.070 ms
8 swiYV2-G0-3.switch.ch (130.59.36.153) [AS 559] 36.319 ms 38.628 ms 38.218 ms
9 pub1.heig-vd.ch (193.134.216.2) [AS 559] 36.040 ms 38.605 ms 35.909 ms
10 * * *

Belamir
Posts: 32
Joined: Tue Apr 08, 2008 11:28 pm

Re: New server linkspeed

Post by Belamir » Wed Jul 29, 2009 10:57 pm

Welcome to a standard American link.

aldea
Posts: 6
Joined: Sun Aug 24, 2008 9:54 pm

Re: New server linkspeed

Post by aldea » Thu Jul 30, 2009 11:12 am

Ok, so a standard american link to mume is 200-250ms, anything changed after the server move ?
Some european players must be better off since they now are physically closer to the mume host.

Thanks for reply.

wiseman
Posts: 23
Joined: Mon Jan 19, 2009 6:51 pm

Re: New server linkspeed

Post by wiseman » Thu Jul 30, 2009 6:36 pm

You find 250ms unplayable? Wow.

Andróg
Posts: 204
Joined: Tue Apr 15, 2008 10:10 pm

Re: New server linkspeed

Post by Andróg » Sat Aug 01, 2009 10:17 am

aldea wrote:Ok, so a standard american link to mume is 200-250ms, anything changed after the server move ?
Some european players must be better off since they now are physically closer to the mume host.

Thanks for reply.
Afaik the average american link is now faster than it was to the old server, though not by much, but still. At least that's what I've heard from the americans I've talked to...

Caerroil
Bug Hunter
Posts: 214
Joined: Sun Feb 24, 2008 12:25 pm
Location: Sweden

Re: New server linkspeed

Post by Caerroil » Sun Aug 02, 2009 9:07 am

I have heard of some people from Eastern Europe that got worse links after the move, but a clear majority weren't really affected (since the difference is quite small) and some got a better link. Of all the Americans I've spoken to they have gotten better links, and in some cases a lot better.
I think I heard of some 60-70ms from Florida, which is what my link is at now and I can't say that there is any real difference from my old link, which was 17ms.

aldea
Posts: 6
Joined: Sun Aug 24, 2008 9:54 pm

Re: New server linkspeed

Post by aldea » Sun Aug 02, 2009 10:47 pm

Thanks for reply, i find it pretty amazing that my ISP show 35ms link to the new server while i playing get a 250ms link.
When testing via my ISP looking glass they might use their backbone link to check ping times but the difference shouldnt
be that huge. I had a 30-35ms link to the old server in norway with the same ISP btw.

Kalev
Vala (Mudller)
Posts: 63
Joined: Sat Feb 23, 2008 9:56 pm
Contact:

Re: New server linkspeed

Post by Kalev » Mon Aug 03, 2009 6:26 pm

Try to run traceroute from your own machine [1]. That should help us better figure out where exactly the rather large delay is coming from.

[1] http://www.infopackets.com/news/interne ... ternet.htm

aldea
Posts: 6
Joined: Sun Aug 24, 2008 9:54 pm

Re: New server linkspeed

Post by aldea » Thu Aug 06, 2009 6:42 am

Kalev wrote:Try to run traceroute from your own machine [1]. That should help us better figure out where exactly the rather large delay is coming from.
[1] http://www.infopackets.com/news/interne ... ternet.htm
Ok, i am doing a traceroute from my own network now (i am also firewalled, like the Mume server, see timeout hop 13 below.) Now this is strange, all
of a sudden i get a 40-45 ms link but at the same time the ingame command link still show 200-250ms ?

Spårar väg till mume.org [193.134.218.111]
över högst 30 hopp:

1 1 ms 1 ms 1 ms 192.168.x.x
2 6 ms 6 ms 6 ms gwXX-no22.tbcn.telia.com [90.230.x.x]
3 12 ms 13 ms 13 ms kbn-bb2-link.telia.net [80.91.254.222]
4 18 ms 17 ms 17 ms hbg-bb2-link.telia.net [80.91.254.2]
5 33 ms 27 ms 31 ms ffm-bb2-pos7-0-0.telia.net [213.248.65.121]
6 39 ms 38 ms 37 ms zch-b1-link.telia.net [80.91.248.122]
7 39 ms 39 ms 40 ms dante-01287-zch-b1.c.telia.net [213.248.79.190]
8 52 ms 36 ms 36 ms swiZH2-10GE-1-3.switch.ch [130.59.36.130]
9 56 ms 41 ms 42 ms swiNE2-G2-3.switch.ch [130.59.36.97]
10 40 ms 40 ms 40 ms swiNE1-G1-4.switch.ch [130.59.36.117]
11 58 ms 40 ms 40 ms swiYV2-G0-3.switch.ch [130.59.36.153]
12 42 ms 48 ms 42 ms pub1.heig-vd.ch [193.134.216.2]
13 * * * Begäran gjorde timeout.

Andróg
Posts: 204
Joined: Tue Apr 15, 2008 10:10 pm

Re: New server linkspeed

Post by Andróg » Fri Aug 07, 2009 12:13 pm

I think that's normal, the two ways of pinging use different methods of reaching the result. For example I get 192ms with the "link" command and 63ms by pinging pub1.heig-vd.ch from command.

aldea
Posts: 6
Joined: Sun Aug 24, 2008 9:54 pm

Re: New server linkspeed

Post by aldea » Sat Aug 08, 2009 9:12 pm

So it seems my case is solved, ii dont have a 250ms link to the new Mume server but a 50ms link.
Below is a ping output, average is 49ms which isnt that bad.

Skickar signaler till pub1.heig-vd.ch [193.134.216.2] med 32 byte data:

Svar från 193.134.216.2: byte=32 tid=41ms TTL=239
Svar från 193.134.216.2: byte=32 tid=56ms TTL=239
Svar från 193.134.216.2: byte=32 tid=57ms TTL=239
Svar från 193.134.216.2: byte=32 tid=44ms TTL=239

Ping-statistik för 193.134.216.2:
Paket: Skickade = 4, mottagna = 4, Förlorade = 0 (0 %),
Ungefärligt överföringstid i millisekunder:
Lägsta = 41 ms, Högsta = 57 ms, Medel = 49 ms

Locked